首页 股票学校 股票入门 选股技巧 买入 卖出 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 视频教程 

767股票学习网 > 股票书籍 > 如何编写股票公式 > 正文

第六讲:均线(选股)的基本形态

  9、三线同时金叉
  A5:=MA(C,5);
  A10:=MA(C,10);
  A20:=MA(C,20);
  AA:=CROSS(C,A5);
  BB:=CROSS(C,A10);
  CC:=CROSS(C,A20);
  AA AND BB AND CC;
  
  10、均线多头排列
  A1:=MA(C,N1);
  A2:=MA(C,N2);
  A3:=MA(C,N3);
  A4:=MA(C,N4);
  A1>A2 AND A2>A3 AND A3>A4;
  
  11、均线空头排列3天以上
  A1:=MA(C,N1);
  A2:=MA(C,N2);
  A3:=MA(C,N3);
  A4:=MA(C,N4);
  COUNT(A1< A2 AND A2< A3 AND A3< A4,3)>=3;

  12、向前N日至M日出现过均线死叉(P1< P2)
  AA:=MA(C,P1);
  BB:=MA(C,P2);
  CC:=REF(CROSS(BB,AA),N);
  COUNT(CC,M);
 
  13、均线粘合
  MA1:=MA(C,5);
  MA2:=MA(C10);
  MA3:=MA(C,20);
  P1:=ABS(MA1-MA2)+ABS(MA2-MA3);
  P1/C<1/100 AND MA1>REF(MA1,1) AND MA2>REF(MA2,1); 

  14、均线粘合(另种表达式)
  MA1:=MA(C,5);
  MA2:=MA(C,10);
  MA3:=MA(C,30);
  A:=MAX(MAX(MA1,MA2),MA3);
  B:=MIN(MIN(MA1,MA2),MA3);
  COUNT(ABS(A-B)/B<0.01,3)=3;表示已粘合3天(含3天)以上

  15、多条均线粘合  如5、10、20、30、120、250日移动平均线粘合
  aa:=(ma(c,5)+ma(c,10)+ma(c,20)+ma(c,30)+ma(c,120)+ma(c,250))/6;
  up:=aa*n/100+aa;
  down:=aa-aa*n/100;
  count(BETWEEN(ma(c,5),up,down) and BETWEEN(ma(c,10),up,down) and BETWEEN(ma(c,20),up,down) and BETWEEN(ma(c,30),up,down)and BETWEEN(ma(c,120),up,down) and BETWEEN(ma(c,250),up,down),m)=m;
    n(2,1,500) m(10,1,100) 调整参数n为粘合程度,n值越小粘合的程度越高,即均线距离越近;m为粘合周期。

  16、乖离均线
  BIAS1:(CLOSE-MA(CLOSE,N))/MA(CLOSE,N)*100;
  当日股价与N日均线的乖离率=(当日股价-N日均价)/N日均价*100; 
  特别提示:乖离均线是由乖离率的“点”连成的均线。 此线虽非普通均线,因常用,故单提出来。
  原理:以当日的均线价格为准,股价和均价之间的差距称为乖离程度,以乖离程度除以均价的百分比就是乖离率。

上一篇文章:

下一篇文章:

 




767股票学习网 | 微信公众号 | 联系站长