首页 股票学校 股票入门 选股技巧 买入 卖出 看盘 跟庄 短线 炒股技巧 技术指标 k线图 MACD 均线 成交量 股票书籍 视频教程 

767股票学习网 > 股票书籍 > 如何编写股票公式 > 正文

第六讲:均线(选股)的基本形态

第六讲:均线(选股)的基本形态

  提示:K线的初步平均。(O+H+L+C*2)/5; 或  (H+L+C*2)/4; 
 
  一般认为:收盘价是最有说服力的和最有价值的,它是每天激烈争夺的最后妥协。但也有人认为:收盘价固然重要,其他价格也是争夺的产物。所以将全天的几种价格因素都考虑进去更能反映每天的真实情况。
  
  1、最简单的指标线
  (1)均价线 就是 移动平均线MA,“MA”表示的就是计算平均值。
  MA1=MA(CLOSE,5);5日平均线=(今天收盘价+昨天收盘价+.....--5天前的收盘价)/5;
  MA2=MA(CLOSE,10);10日平均线=(今天收盘价+昨天收盘价+......+10天前的收盘价)/10;
  (2)均量线 均价线会了,照着葫芦画瓢,把收盘价CLOSE换成成交量VOL就行了!
  例:MA1:MA(VOL,5);
  MA2:MA(VOL,10);
  
  2、再次平均 指将已有的均线(多条均线)相加后进行再平均。
  MA1=MA(CLOSE,5);
  MA2=MA(CLOSE,10);
  (MA1+MA2)/2;
  
  3、N日均线向上 (本题反映均线波浪式延伸过程中某阶段的形态。)
  AA:=MA(C,N);
  BB:=REF(AA,1);
  AA>BB
 
  均线向下呢? AA< BB 就可以了。
  N日均线走平怎么表述?AA=BB
  
  4、均线由下跌状态刚刚转为上升
  AA:=MA(C,N);
   COUNT(AA<REF(AA,1),6)=5   //用来确认前5日处于下跌状态
    AND AA>REF(AA,5);
  
  5、年线拐头向上
  A250:=MA(C,250);
  REF(A250,1)<REF(A250,2) AND A250>REF(A250,1);
  
  6、两条均线交叉
  股软中专门设定了一条函数来描述两条线交叉:CROSS(X,Y) ,此函数通用。
  假如两条均线一条名叫X,另外一条叫Y  且(X<Y)
  CROSS(X,Y)表示X向上穿过了Y  通称:金叉
  CROSS(Y,X)表示Y向上穿过了X  通称:死叉
  特别提示:交叉有两种,一种是向上交叉,另一种是向下交叉。如果要求向上交叉时,X线必须比前一天高,所以需要加上 X>REF(X,1) 。完整的表达式为:CROSS(X,Y)AND  X>REF(X,1)
  加餐:
  上述交叉是不限制周期的,有时我们会感到交叉特别频繁,如何取得他们较长时间交叉一次的数据呢,系统提供了另一个函数: LONGCROSS(X,Y,N) 两条线维持N周期后交叉。如果N等于15,则X Y两条线超过15天后交叉有效,否则不输出。
  
  7、多次金叉(以常见的MACD指标为例)
  (1)二次金叉
  (COUNT(CROSS(DIF,DEA),20)=2 AND CROSS(DIF,DEA);
  (2)二次死叉
  COUNT(CROSS(DEA,DIF),20)=2 AND CROSS(DEA,DIF);
  (3)0轴上二次金叉
  COUNT(CROSS(DIF,DEA) AND DEA>0,20)=2 AND CROSS(DIF,DEA) AND
  DEA>0;
  (4)0轴上三次金叉
  COUNT(CROSS(DIF,DEA) AND DEA>0,20)=3 AND CROSS(DIF,DEA) AND
  DEA>0;
  
  8、三线金叉
  A5:=MA(C,5);
  A10:=MA(C,10);
  A30:=MA(C,30);
  AA:=CROSS(A5,A10);
  BB:=CROSS(A5,A30);
  CC:=CROSS(A10,A30);
  COUNT(AA,3)=1 AND COUNT(BB,3)=1 AND COUNT(CC,3)=1;

上一篇文章:

下一篇文章:

 




767股票学习网 | 手机版 | 微信公众号 | 联系站长